1.2.13b7 installation problem

This forum has been archived and is no longer active.

The new forum is located at:

https://sourceforge.net/apps/phpbb/installjammer/

You may continue to view and search the topics in this forum, but no new posts can be created.

1.2.13b7 installation problem

Postby uros_krkic » Mon Jun 29, 2009 5:52 pm

Everything works with b5, but b7 has the problem.

What is it?

When I click Next on the pane "Start copying files...", during the file copying progress, I got the message: Error occurred (something like that) with OK button. After clicking on OK, it continues (unsuccessfully), and on finish pane, it display the error message with content:

error deleting "E:/Program Files/MyApp": directory not empty
error deleting "E:/Program Files/MyApp": directory not empty
while executing
"file delete $force $dir"
(procedure "::InstallJammer::UninstallDirectory" line 2)
invoked from within
"::InstallJammer::UninstallDirectory {E:/Program Files/MyApp}"
("eval" body line 1)
invoked from within
"eval ::InstallJammer::UninstallDirectory $dir"
(procedure "::InstallJammer::CleanupCancelledInstall" line 53)
invoked from within
"::InstallJammer::CleanupCancelledInstall"
(procedure "::InstallJammer::exit" line 42)
invoked from within
"::InstallJammer::exit"
(procedure "::InstallJammer::FinishEventHandler" line 7)
invoked from within
"::InstallJammer::FinishEventHandler .wizard"
(command bound to event)

Everytime, I click Finish, this message box re-appears. I must close the installer via TaskManager. Again, everything works with b5.

Regards,
Uros
uros_krkic
 
Posts: 63
Joined: Sat Feb 09, 2008 10:02 pm

Re: 1.2.13b7 installation problem

Postby damon » Mon Jun 29, 2009 7:28 pm

Do you mean when you cancel a running installation? Is E:/Program Files/MyApp empty, or does it still have files in it?

The installer is trying to cleanup the canceled install, but it's failing because the directory is not empty (or so it says). That's where the error is coming from, but I need to know more about what's in that directory when you try to cancel.
To file an issue, please visit:

http://tracker.installjammer.com/
damon
Site Admin
 
Posts: 4404
Joined: Sat Sep 15, 2007 2:46 pm

Re: 1.2.13b7 installation problem

Postby uros_krkic » Tue Jun 30, 2009 2:59 pm

I don't cancel the installation process. The problem occurred during the installation process during Copying files pane... It seems like the installer try to delete the install_dir after the files are copied.
uros_krkic
 
Posts: 63
Joined: Sat Feb 09, 2008 10:02 pm

Re: 1.2.13b7 installation problem

Postby damon » Tue Jun 30, 2009 3:23 pm

So, your installer installs all the files and runs to the end, and then you get this error? That doesn't make sense. The error you're seeing should only occur when the install is canceled. That's what the stack trace is telling me.

Do you get this every single time? Try creating a new project, add some dummy files to it and install it and tell me if you get the same thing.
To file an issue, please visit:

http://tracker.installjammer.com/
damon
Site Admin
 
Posts: 4404
Joined: Sat Sep 15, 2007 2:46 pm

Re: 1.2.13b7 installation problem

Postby uros_krkic » Sat Jul 04, 2009 4:01 pm

In 168555 revision, you fixed the problem. Am I right ?

Now, everything works normal. So, please ack this, to know if something goes wrong with my build process, or you really fixed the problem.

Thanks,

Best regards,
Uros
uros_krkic
 
Posts: 63
Joined: Sat Feb 09, 2008 10:02 pm

Re: 1.2.13b7 installation problem

Postby hardy » Fri Jul 15, 2011 2:59 am

Hey ,
I am facing the same problem .But When i cancel the Setup in between the Progress bar or At the time when installation is going on.
Any help.....:)

-hardy
Hardy...
hardy
 
Posts: 15
Joined: Mon Feb 28, 2011 3:08 am


Return to Help

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron